Degraded performance
Incident Report for Silverfin
Resolved
This incident has been resolved.
Posted Oct 24, 2023 - 11:21 CEST
Identified
We have identified the issue and are looking into resolving the issue at the moment.
Posted Oct 24, 2023 - 10:07 CEST
Investigating
We are experiencing degraded services for a small amount of customers. This means that you can experience for example slow loading speeds. We are investigating the issue and will provide an update as soon as possible.
Posted Oct 24, 2023 - 09:20 CEST
This incident affected: Silverfin (Silverfin).