Update Incident 28/09/2023
Incident Report for Silverfin
Resolved
We’ve concluded our investigation on the incident of last week (28 September). We want to share our analysis in the interest of transparency, even though most environments were not impacted:
A rollback to a previous version of Silverfin caused a very limited set of users to have temporary access to client files in another environment. Based on our analysis and detailed logs, we know 34 users in a total of 20 environments were affected. All impacted Silverfin customers have been personally contacted and informed of the specific actions that happened during the 2h time window this change was active.
We take security very seriously and have done a thorough root cause analysis. We are working on modifying our process, so this can’t happen in the future, and be detected earlier should a new root cause create a similar outcome. Overall, we would like to apologise that this could happen in the first place.
Posted Oct 02, 2023 - 20:10 CEST
This incident affected: Silverfin (Silverfin).