Adjustments & Slow performance

Incident Report for Silverfin

Resolved

The fix have been implemented. We are currently still monitoring the system. If you are still experiencing issues, please do not hesitate to contact our support! Our apologies for the inconveniences!
Posted Dec 03, 2025 - 18:21 CET

Update

We are continuing to investigate this issue.
Posted Dec 03, 2025 - 17:54 CET

Investigating

We have been made aware that adding new adjustments isn’t possible at the moment. We’re working on a solution and will let you know as soon as the fix is live. This can also impact the communication tab.
Posted Dec 03, 2025 - 17:51 CET
This incident affected: Silverfin (Silverfin).